Getting started

System requirements

  • Node: The current LTS (long-term support) release. We like to use a Node Version Manager like NVM.
  • NPM 5+ or Yarn: Both of these package managers have ups and downs, choose whichever you prefer. Follow the installation instructions for Yarn or NPM to make sure you're using the latest version.

Setup

Assuming you are using Yarn;
  1. 1.
    Fork the master branch
  2. 2.
    Install dependencies $ yarn
  3. 3.
    Create and configure your .env file
  4. 4.
    Run $ yarn start
  5. 5.
    Get coding!

The .env file

A sample .env file is provided. Create new .env files as needed by adding a unique enxtension name.
For example; a production environment .env file may be named .env.production
.env.production
1
SLATE_STORE=[YOUR_STORE].myshopify.com
2
SLATE_PASSWORD=[YOUR_API_PASSWORD]
3
SLATE_THEME_ID=[YOUR_THEME_ID]
4
SLATE_IGNORE_FILES=config/settings_data.json
Copied!
Last modified 1yr ago